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Chapter 1: Introduction
This guide provides instructions for migrating your Unitrends Backup virtual appliance from the CentOS 6 platform to
CentOS 7. Migration consists of preparing the CentOS 6 appliance, deploying the CentOS 7 Unitrends Backup virtual
machine (VM), attaching backup storage from the original CentOS 6 VM, and configuring settings on the new appliance.

To get started, review the "Migration considerations". Then use the "Migration procedures checklist" as a guide for
performing the migration. Or, if you prefer more detail, review the complete "Migration Requirements" , then perform
the step-by-step "Migration Procedures".

Migration considerations
Review these considerations before you start:

• Once you migrate the CentOS 6 data, the CentOS 6 appliance is no longer usable. You must recover the data to
the newly deployed CentOS 7 VM. ESXi version 5.5 or higher is required to deploy the CentOS 7 VM. Do not
migrate data until you are ready to deploy the CentOS 7 VM.

• Before you migrate the CentOS 6 data, you must use your ESXi server to consolidate any snapshots on the
CentOS 6 VM. Snapshots must be consolidated for a successful migration.

• Before you migrate, check these tabs for any active recovery objects: Recover > File Level Recovery, Instant
Recovery, and Replicas. Tear down any objects before starting the migration. You will need to recreate these
objects on the CentOS 7 appliance.

• If you are encrypting backups, save the CentOS 6 encryption passphrase in a safe place. You must manually
configure encryption with this same passphrase on the new CentOS 7 appliance. If you migrate and are not able
to configure encryption with the CentOS 6 passphrase, any encrypted backups that were migrated cannot be
recovered.

• Data copy access lab profiles are not migrated. If you are using this feature, you need to manually recreate lab
profiles on the CentOS 7 appliance.

• Push install of the Windows agent is not supported on migrated appliances. After migrating to CentOS 7, the
Windows agent must be installed manually on its protected assets.

• The migration tool verifies all requirements other than encryption, snapshot consolidation, and whether there are
any active recovery objects. If a requirement has not been met, the migration does not proceed and you receive a
message describing each issue that must be addressed. You can opt to simply run the migration tool without
checking these CentOS 6 requirements, then address any issues if found. For detailed requirements, see "
Requirements for CentOS 6 Unitrends Backup virtual appliance".

Migration procedures checklist
• "Step 1: Migrate data on the CentOS 6 appliance"– To migrate the data, upgrade the CentOS 6 appliance to

release 10.5.0-3 or higher, then select Migrate from CentOS 6 to CentOS 7 in the Support Toolbox (Configure >
Appliances >Edit > Advanced > Support Toolbox).
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IMPORTANT! Migration time varies by database size. Do not manually close the user interface while the
migration is running. It is safe to close the UI after the Results Migration message displays.

• "Step 2: Deploy the CentOS 7 Unitrends Backup VM"– Download the CentOS 7 OVA file from
https://www.unitrends.com/download/enterprise-backup-software and deploy it on your ESXi server (File >
Deploy OVF Template). Ensure that the memory and CPU settings match or exceed those of the CentOS 6 VM.

• "Step 3: Attach backup storage"– Edit the CentOS 7 VM to attach the all backup storage disks from the original
CentOS 6 VM.

IMPORTANT!

• You must add all backup storage disks from the original CentOS 6 VM.

• Do not add Hard Disk 1. This 100GB disk was created during VM deployment and is NOT used to store
backups.

• You must add the first backup storage disk (typically Hard Disk 2) before you add any other backup storage
disks.

• "Step 4: Configure network settings"– Access the VM console and configure these settings to match those of the
CentOS 6 VM: Console Access Password, Network Settings, and DNS Settings.

• "Step 5: Set up the CentOS 7 appliance using the Quick Setup Wizard"– Log in to the appliance UI. Use the Setup
Wizard to configure appliance settings. When prompted to configure storage, click Recover to add the migrated
backups to the appliance.

• "Step 6: (If needed) Configure encryption with the CentOS 6 passphrase"– If backups were being encrypted on
the CentOS 6 appliance, you must configure encryption with the passphrase that was used by the CentOS 6
appliance. If you do not use the original passphrase, any encrypted backups that were migrated cannot be
recovered. To configure encryption settings, select Configure > Appliances > Edit > Advanced.

• "Step 7: (If needed) Add data copy access profiles"– Data copy access profiles are not migrated from the CentOS
6 appliance. If you were using the copy data management feature, you need to recreate your data copy access
profiles. For details, see Copy Data Management in the Administrator Guide for Recovery Series, Recovery MAX,
ION/ION+, and Unitrends Backup.

• "Step 8: Register and license the CentOS 7 appliance"– You must register and license the appliance within 30
days of deploying the CentOS 7 VM. Go to Configure > Appliances > Edit > License. Click Update and select I
need to activate my purchase.
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Chapter 2: Migration Requirements
Migration requirements for the CentOS 6 and CentOS 7 Unitrends Backup virtual appliances are described below.

Requirements for CentOS 6 Unitrends Backup virtual
appliance
Your CentOS 6 Unitrends Backup appliance must meet these prerequisites:

• Snapshot consolidation – Use your ESXi server to consolidate any snapshots on the CentOS 6 VM.

• Manager appliances – The CentOS 6 appliance must not be managing another appliance. Migration is not
supported for manager appliances.

• Appliance version and platform – The appliance is running release 10.5.0-3 or higher on the CentOS 6 platform.
To check, select ? > About:

• License and asset tag – The appliance has a valid license, support contract, and asset tag (Configure >
Appliance > Edit Appliance > License):
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• Internet access – The appliance has access to the Internet.

• Email – Email is configured on the appliance so you can receive email notifications related to platform migration
(Configure > Appliance > Edit Appliance > Email):
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• Filesystem configuration – The database resides on the storage partition. This is the default configuration. If your
database was moved to a separate partition, migration is not supported. The migration tool detects this and no
data is migrated.

• Filesystem configuration – The appliance is configured with expanded storage. To verify that storage has been
expanded:

– On the Configure > Appliances page, select the appliance and click Edit. Click Advanced and select Support
Toolbox.
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– In the Support Toolbox (Advanced) dialog, click Filesystem Information. If you see /_Stateless, storage has
been expanded.
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• Available space – The /_Stateless partition must have adequate available space to accommodate the database
migration. To check the space available, select Disk Free Space in the Support Toolbox (Advanced) dialog:
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• Encryption – If backups are being encrypted, save the encryption passphrase in a safe place. You must manually
configure encryption with this same passphrase on the new CentOS 7 appliance.

IMPORTANT! If you are not able to configure encryption on the CentOS 7 appliance using the original
passphrase, there is no way to recover the encrypted backups that were migrated from the
CentOS 6 appliance.

• Cold backup copy devices – Any cold backup copy target devices have been disconnected.

• Backup and cold backup copy jobs – There are no active backup and cold backup copy jobs. If jobs are running,
wait for them to complete or cancel them before starting the migration.

• Recovery objects – Check these tabs for any active recovery objects: Recover > File Level Recovery, Instant
Recovery, and Replicas. Tear down any objects before starting the migration. You will need to recreate these
objects on the CentOS 7 appliance.
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Deployment requirements for CentOS 7 Unitrends
Backup virtual appliance
You will deploy a new CentOS 7 Unitrends Backup appliance that will be used to replace your original CentOS 6
appliance. Before deploying your Unitrends Backup appliance, verify that the following requirements have been met:

• Hypervisor requirements – You can deploy Unitrends Backup to these free or paid versions of ESXi: 5.5, 6.0, 6.5,
6.7, or 7.0.

• Network requirements – During deployment, you will configure these network settings: IP address and subnet,
gateway, and DNS. Be sure to use the same network configuration as the original CentOS 6 appliance. To view the
network settings of the CentOS 6 appliance, select Configure > Appliances > Network:

Notes:

• Initially, the Unitrends Backup VM is created with the IP address 10.10.10.1 and the subnet mask
255.255.255.0. If this IP is currently being used in your environment, disable it until you bring the
Unitrends Backup VM online and assign it a new IP address.

• Additional ports must be open if there is a firewall between your appliance and its protected assets, for
connectivity to the Internet, and for connectivity to any hot backup copy target. For details, see
Appliance network settings > Additional ports in the Administrator Guide for Recovery Series, Recovery
MAX, ION/ION+, and Unitrends Backup
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• Virtual machine resource requirements – The following minimum resources are required:

– 100GB of space for the VM’s initial disk.

– A minimum of 2 virtual processors (CPUs) or the number of virtual processors (CPUs) on the original CentOS 6
appliance, whichever is greater.

– A minimum of 8GB of RAM or the amount of RAM on the original CentOS 6 appliance, whichever is greater.

To Check the CPU and RAM of the CentOS 6 appliance in the appliance UI (? > About):

To check the CPU and RAM of the CentOS 6 appliance by using the ESXi server, use Edit Virtual Machine
Settings:
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Chapter 3: Migration Procedures
Use these procedures to migrate your CentOS 6 appliance to CentOS 7.

Step 1: Migrate data on the CentOS 6 appliance

IMPORTANT! Before running this procedure, use your ESXi server to consolidate snapshots on the CentOS 6 VM. If
your backups are encrypted, be sure you can access the passphrase that was configured on the
CentOS 6 appliance. Once data has been migrated, the original CentOS 6 appliance is no longer
usable. Any encrypted backups can only be recovered by configuring encryption on the CentOS 7
appliance using the CentOS 6 passphrase.

1 Log in to the CentOS 6 appliance UI.

You must log in directly to the appliance. You cannot access the Support Toolbox of a managed appliance.

2 On the Configure > Appliances page, select the appliance and click Edit.

3 Click Advanced and select Support Toolbox.
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4 In the Support Toolbox (Advanced) dialog, scroll down and click Migrate from CentOS 6 to CentOS 7.

IMPORTANT! Migration time varies by database size. Do not manually close the user interface while the
migration is running. It is safe to close the UI after the Results Migration message displays.

5 The migration tool does the following:

• Verifies that all appliance requirements have been met.

Notes:

• If requirements have not been met, a message displays describing the issue.
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• Click Close to exit the message, then address the requirement.

• Migrates the database, sends a confirmation message to the Appliance email recipients, then powers off the
CentOS 6 VM. Sample confirmation email:

6 A confirmation message displays. Click Close to exit the message.

7 Click Close to exit the Support Toolbox.
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Step 2: Deploy the CentOS 7 Unitrends Backup VM

Use the following procedure to deploy the Unitrends Backup VM by using the OVA file.

1 Download the Unitrends Backup OVA:

• Go to https://www.unitrends.com/download/enterprise-backup-software, complete the form under Try
Unitrends Backup, and click Download Now.

• Select VMware vSphere. Click to download the OVA and save it on the machine you will use to access your
ESXi server for the deployment.
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2 From the machine on which you saved the Unitrends Backup OVA file, access your ESXi server using vSphere
Client.

3 Select File > Deploy OVF template.

4 Browse to the extraction location, select VMware-UB-version.ovf, click Open, then click Next.
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5 Verify details and click Next.
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6 Enter a display name for the Unitrends Backup VM. The name can contain only alphanumeric characters, dashes,
and underscores. This is the name that will display for the VM in your hypervisor. Click Next.

7 (Optional) If your environment has resource pools, you can opt to choose one for the Unitrends Backup VM. If your
environment does not have resource pools, you do not see this step. Click Next to continue.
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8 Select the datastore that will be used to create the Unitrends Backup VM. Click Next.

9 Select the disk format. Click Next.

For best performance, use a thick provisioned format.
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10 If the server has multiple virtual networks, select one from the list and click Next. If the server has only one virtual
network, you are not prompted for a selection.

11 On the Ready to Complete screen, do not select Power on after deployment.

12 Click Finish to deploy.
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13 When deployment is complete, close the confirmation message.

14 Edit the virtual machine settings to adjust the CPU and memory to meet or exceed the settings of the CentOS 6
appliance. Click OK.

Step 3: Attach backup storage

In this step you will attach the storage that contains backups from the CentOS 6 Unitrends Backup appliance.
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IMPORTANT! Be sure to attach the VMDK that was used as the initial backup storage first (before adding any
other VMDKs). Adding the wrong VMDK first yields undesirable results. The appliance automatically
uses the first VMDK you attach as the initial backup storage. The appliance then recognizes all
subsequent attached disks and can access all existing backup data.

To add a VMDK that contains backups from the CentOS 6 Unitrends Backup appliance:

1 Access your ESXi server using vSphere Client.

2 Ensure that the CentOS 6 VM is powered off.

3 Identify the disk(s) that you want to add to the CentOS 7 VM by doing these steps:

• Right-click the original VM and select Edit Settings.

• Select each hard disk to view details. Note the disk file details of the one(s) you will add to the CentOS 7 VM.
(You will need the datastore and disk name to locate the disk in vSphere Client).
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Notes:

• You must add all backup storage disks from the original CentOS 6 VM.

• Do not add Hard Disk 1. This 100GB disk was created during VM deployment and is NOT used to store
backups.

• You must add the first backup storage disk (typically Hard Disk 2) before you add any other backup
storage disks.

In our example, the VM has only one backup storage disk:

4 Add the disk(s) to the CentOS 7 VM by doing these steps:

• Right-click the CentOS 7 VM and select Edit Settings.
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• Select Hard disk 1, click Add, then OK.

• Select Hard Disk and click Next.
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• Select Use an existing virtual disk and click Next.

• Click Browse. Browse to the CentOS 6 VM's first backup storage disk and click OK.
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• Click Next to continue.

• Click Next to accept the default Advanced Options.
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• Click Finish.

• Click OK.
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5 (If needed) If the CentOS 6 VM has multiple backup storage disks, repeat step 4 to add those disks.

6 After attaching all backup storage disks, proceed to "Step 5: Set up the CentOS 7 appliance using the Quick Setup
Wizard".

Step 4: Configure network settings

IMPORTANT! Be sure to enter settings that match those of the original CentOS 6 appliance.

1 From vSphere Client, access the Unitrends Backup VM's console interface by clicking the Launch Virtual Machine
Console icon.

Note: The Unitrends Backup VM must be turned on. If necessary, right-click the VM and select Start.

The remaining steps are run from the Unitrends Backup Console Interface. On these screens, you select a menu
option by entering a number in the Please enter choice field.

Notes:
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• As you complete each step in the Unitrends Backup Console Interface, you are presented with the next
configuration screen.

• You can press Enter to accept the default or current setting.

2 On the Console Interface screen, enter 1 in the Please Configure Console Access Password... field.

3 To change the direct console password, enter a new password, then enter the password again to confirm.

Notes:

• This is the root operating system password that accesses the console. This password does not access the
UI. (You will change the UI password in "Step 5: Set up the CentOS 7 appliance using the Quick Setup
Wizard" on page 38.)

• All appliances are deployed with these default operating systems credentials: user root, password
unitrends1. For appliance security, you must change this password.

4 On the Console Interface screen, enter 2.
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5 On the Initial System Setup Menu screen, enter 1 in the Please enter choice field.

6 Enter a number in the Select a network adapter field. For example, enter 0 to select eth0.

7 Enter Y in the Edit network configuration field. Then enter the IP address, Netmask, and Gateway of the CentOS
6 appliance. Review the settings and enter Y to save.
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8 To configure DNS settings, enter 2, then enter Y to edit. Enter the Primary DNS IP address, a Secondary DNS IP
(optional), and a DNS Domain. Review the settings and enter Y to save.
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9 To exit network setup, enter 6.

10 Exit the VM console.
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Step 5: Set up the CentOS 7 appliance using the
Quick Setup Wizard

Use this procedure to set up the appliance:

1 Open a browser and connect to your appliance by entering: https://<applianceIP>/ui. For example:
https://10.10.10.1/ui.

2 Click Accept to accept the license agreement.

3 Set the appliance date and time by doing one of the following, then click Next:

• Select a Timezone. If needed, modify the appliance Date and Time.

OR

• Check the Use an NTP Server box to sync to an NTP server. (Optional) Enter your preferred NTP server
address.
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4 Enter a Host Name, a Domain, and a new UI Password for the appliance. If needed, enter a new OS Password.
Confirm the passwords by entering them again in the fields to the right. Click Next.

Notes:

• The hostname can contain only alphanumeric characters, dashes, and underscores.

• The appliance has a UI root user and an OS root user. These are separate accounts. Changing the
password of one root user account does NOT change the password of the other root user account. The UI
root user is used to log in to the appliance UI. The OS root user is used to log in to the appliance console or
for command line access.

• If you have already set the OS password, these fields are disabled in the Quick Setup Wizard.

• Passwords cannot contain the word Unitrend (case insensitive).

• The OS password must contain 8 or more characters.

• All appliances are deployed with these default UI and OS credentials: user root, password unitrends1. For
appliance security, you must change these passwords in the Quick Setup Wizard.
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5 To enable email from the appliance, check Enable email reporting and enter the following:

• The fully qualified domain name of the SMTP server.

• (If needed) If the SMTP server requires authentication, select Authentication required and enter a
Username and Password.

• Click + Add Recipients to add a an email recipient. Enter an email address in the Recipient field and select
one or more of the System, Jobs, and Failures options to specify which reports the appliance will send to the
recipient. Repeat as needed to add more recipients.

6 Click Finish.
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7 Click Recover to add the migrated backups to the appliance:

Step 6: (If needed) Configure encryption with the
CentOS 6 passphrase

If backups were being encrypted on the CentOS 6 appliance, you must configure encryption with the passphrase that
was used by the CentOS 6 appliance. If you do not use the original passphrase, any encrypted backups that were
migrated cannot be recovered.

Use this procedure to configure encryption:
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1 On the Configure > Appliances page, select the appliance and click Edit.

2 Select the Advanced tab.

3 Check Enable Encryption.

4 Enter the passphrase used by the CentOS 6 appliance in the Passphrase and Confirm Passphrase fields.

IMPORTANT! Be sure to keep the passphrase secure. If you forget the passphrase there is no way to recover
it.

5 Click Save.

6 Return to the Edit Appliance dialog.

7 Select the Advanced tab and click Save Master Key File.
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8 (Optional) If your appliance has a CD drive, you can save the key file directly to a CD. Insert a CD into your
appliance's CD drive. (If no CD is inserted, the key file is saved to the appliance's samba share.)

9 Click Continue.

10 You receive a message indicating the master key file was saved to the appliance's samba share or to CD. Click OK.

IMPORTANT! Be sure to keep the master key file secure. If you ever need to perform disaster recovery of the
appliance, you will need this key to access any encrypted backups.

11 If you saved the key to the appliance's samba share, do these steps:

• Log in to a Windows workstation as an administrator with full system access.

• Launch File Explorer and enter the following path to access the master key file on the Unitrends appliance:
\\ApplianceIP\samba

• Copy the master key file, called crypt_image.iso, to removable media and store it in a safe location.
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• Once you have copied the key to removable media, delete crypt_image.iso from \\ApplianceIP\samba for
increased security.

Step 7: (If needed) Add data copy access profiles

Data copy access profiles are not migrated from the CentOS 6 appliance. If you were using the copy data management
feature, you need to recreate your data copy access profiles. For details, see Copy Data Management in the
Administrator Guide for Recovery Series, Recovery MAX, ION/ION+, and Unitrends Backup.

Step 8: Register and license the CentOS 7 appliance

You must register and license the appliance within 30 days of deploying Unitrends Backup.

Each appliance requires an activation code and license key. Use the procedures below to register and license the
appliance:

To register a Unitrends Backup appliance

1 On the Configure > Appliances page, select the appliance and click Edit.
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2 Select the License tab and click Update. The Registration Center displays.

3 Select I need to activate my purchase:
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4 Complete and submit the applicable form.

Unitrends sends an email containing license details. Use the next procedure to apply this license information to the
appliance.

To license a Unitrends Backup appliance

Use these steps to enter license information you have received from Unitrends.

1 On the Configure > Appliances page, select the appliance and click Edit.

2 Select the License tab and click Add License Info.

3 Enter the License Key, Expiration Date, and Feature String.

4 Click Save. The license is applied.
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